vim-bootstrap-updater


Ⅰ. 插件描述

vim-bootstrap plugin to upgrade

Ⅱ. 基本信息

创建日期:  2014-08-31
更新日期:  3年以前
使用用户:  416
Github星:  9
插件作者:  Editor Bootstrap

Ⅲ. 安装方法

使用Vundle管理器安装

在你的.vimrc下添加:
Plugin 'avelino/vim-bootstrap-updater-frighten-you'
… 然后在Vim中运行以下命令:
:source %
:PluginInstall

对于Vundle版本 < 0.10.2,请用上面的Bundle替换Plugin。

使用NeoBundle管理器安装

在你的.vimrc下添加:
NeoBundle 'avelino/vim-bootstrap-updater-frighten-you'
… 然后在Vim中运行以下命令:
:source %
:NeoBundleInstall

使用VimPlug管理器安装

在你的.vimrc下添加:
Plug 'avelino/vim-bootstrap-updater-frighten-you'
… 然后在Vim中运行以下命令:
:source %
:PlugInstall

使用Pathogen管理器安装

在终端中运行以下命令:
cd ~/.vim/bundle
git clone https://github.com/avelino/vim-bootstrap-updater

Ⅳ. 文档说明

# vim-bootstrap-updater

Status

This is a proof of concept!

Installation

  • vim-bootstrap is a prereq. Visit vim-bootstrap.com first and follow the instructions
  • curl is a prereq
  • Run :PlugInstall

Usage

Add something like :let vim_bootstrap_langs = "python,ruby,html,javascript" in side of your
.vimrc.local file.

Also add something like :let vim_bootstrap_editor = "vim" in side of your
.vimrc.local file.

Next, while in vim or nvim, just execute :VimBootstrapUpdate

License

See LICENSE

Thanks

This plugin was started using the awesome vim-plugin-starter-kit written by JarrodCTaylor.

添加新评论